• Welcome to XOTIC PC Forums! If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Game problem (No not Bioshock lol)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Game problem (No not Bioshock lol)

    Hello, I just got World in Conflict and I must say it is a really good game, beautiful everything. So in their graphics setting stuff they have a option to do a benchmark to see how your system does against the game, it seems to run fine, but when there is nothing new going on, I guess lets say a guy running not much changing in the background etc. it skips frames. Now there are big explosions and such which if I have it running on full everything it lags down to about 7 or so frames. The strange thing is when it is at higher FPS it skips a few frames and doing so it drops the frame rate considerably when I have the game on the lowest settings. On the higher settings it still does it which seems strange that it would it even on the low settings. So I've tried everything, installing new graphic software, cleaning out my HDD, defragging my HDD, cleaning my registry, checking for viruses and spyware, uninstall and reinstall the game, and nothing seems to work. The game is playable like this, but it gets annoying after awhile. I would think that the 7950 GTX would be able to handle this game, albeit it probably is close to the max for the card. So do you think my setting ON the video card itself is the problem or is my lappy not "strong" enough to handle the problem. I don't have many programs running in the background either. I have about 30 at a time and the largest one goes at 30k. If you need the DXdiag file PM me just in case you want it. Would be great to find out what is causing little quirky problem. Thanks!

    Sager 5790
    Intel duo 2 @ 2.0 GHz
    2 GIG of RAM
    7200 RPM 160 GIG HDD with 65 GIG free
    XP Pro SP2
    Direct X 9c
    Sager NP8170
    Threedee Screen, GTX 485M, i7-2720QM, IC Diamond paste, BlueRay Drive
    Phase 1 - 7/5
    Phase 2 - 7/11
    Phase 3 - ?
    Phase 4 - 7/25 (does it have to be a Monday? -.-)

    T minus 1 phase til awesomeness!

  • #2
    Unfortunately your not the first person to say that your having problems with World in Conflict. I've already had numerous people question there laptops ability to run the game due to problems while playing the game. We all know a 7950 or 8700 can easily handle the game.

    The game itself has problems and the only resolution i can offer you is to wait until a patch or a fix comes out. If you want to contact technical game support call +1 (310) 649 8033

    Comment


    • #3
      Yeah ok. I guess I'm just going to have to wait. Bummer. Got away with Bioshock and this must be payback lol. To many different variables out there for these game companies to get it to work with everyone's machines the first time anymore. I remember back in the day when all you needed was a sound blaster to get the sound to work and enough knowledge to get to DOS and type in the right commands haha. Good times. Anyway, thanks for the help. Just going to have to ride this one out.
      Sager NP8170
      Threedee Screen, GTX 485M, i7-2720QM, IC Diamond paste, BlueRay Drive
      Phase 1 - 7/5
      Phase 2 - 7/11
      Phase 3 - ?
      Phase 4 - 7/25 (does it have to be a Monday? -.-)

      T minus 1 phase til awesomeness!

      Comment

      Working...
      X