• Welcome to XOTIC PC Forums! If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

NP9261: Boot refusal; Vista crashing; BIOS handoff failure

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • NP9261: Boot refusal; Vista crashing; BIOS handoff failure

    Hi everyone,


    Well there's a bit of a list for you.

    I got my NP9261 last week and it seems to have some pretty serious problems. Let's start from the top.

    - Boot failure: this is the one mentioned elsewhere on this forum, where it doesn't even get as far as the power-on splash screen (or the regular BIOS output screen if enabled). This usually happens after an OS crash, but sometimes it occurs after a normal shutdown too. Out-inning the battery as recommended by XoticPC usually helps.
    Does anyone have an actual solution to this problem? The battery thing only addresses the symptom, not the disease. Is it a BIOS problem? (See below.)

    - Vista crashes far more than one would normally expect. I get the sound loop crash mentioned in another post, and I also get the invisible windows crash, where windows are invisible but still present although unresponsive (you can see they're there by the fact that the mouse pointer changes shape when it moves over them).
    Going on-line with this thing in its current state is a haphazard affair and I haven't been able to keep it running for long enough to do the auto-update thing. I've downloaded the most recent Realtek driver at work and will try it out. But can anyone confirm there is an issue with the sound driver (serious enough to crash the OS) in the first place?
    I'm running Vista Ultimate 32, and the only tweak I've done is I switched off the page file. Hey, I've got a whole 4 GB to play with (three of which are even visible to the OS), and the OS itself only requires 650 MB to do nothing at all.

    I also have Debian etch R1 installed. There was an error message during boot off the installation DVD, but it went past it and installed clean. However, I get the same error message when I boot the installation and it freezes at that spot. Here's the message:
    0000:00:1a.7 EHCI: BIOS handoff failed (BIOS bug?) 01010001
    This is a USB-related problem: the BIOS fails to hand off the USB host controller to the OS. The reason the BIOS has it in the first place is in case the machine has a USB keyboard plugged in during boot. So the installed Linux refuses to boot (although the installation DVD went past it just fine), while Vista sees no problem (or just as likely ignores it).
    Can anyone else shed any light on this? Does anyone have a Linux running on one of these beasts, or am I the first to boldly go?
    In another post someone reported a problem with their USB ports (they weren't working so yeah, I'd say that's a bit of a problem), but at least one of mine is working 'cos I've had my mouse in there and had no problems with that (so I didn't bother checking the others). But this could be related.

    I went to the Phoenix web site to look for BIOS updates. It directed me to esupport.com, where you can do a scan. Took me half a dozen attempts due to the laptop keeping crashing on me, but I got there in the end. It gave me the following BIOS info:
    - Type: Phoenix
    - Date: October 12th 2007
    - ID: 6.00
    - OEM: 6.00
    It also said they've got an upgrade for me which they'll ship just as soon as they're back at work on Monday (this was Saturday), at only $29.95. Worth it to get this thing working.
    But here's the thing: it didn't tell me which BIOS I had on there. Neither does the BIOS itself. It comes up with "BIOS Revision: D900C 1.00.07S LS1", but it doesn't say which actual product it is: Phoenix have several.
    Can anyone tell me the name of the BIOS product? And has anyone else got a BIOS update off esupport.com, and did it help?

    Now all that said, I've got a game installed and I can run that just fine, and have had it successfully running for hours (I've had the game itself crash with sound loops occasionally, but can then usually kill it from Vista and fire it up again). I've also had the bare Vista on for hours just sitting there gently leaking memory as any good OS does. While I have had complete OS crashes several times when playing the game, the crashes are most frequent when doing system stuff in Vista - users, security, even firing up the task manager. Not sure if this is random or what, so if anyone has any theories I'd be glad to hear 'em.

    I have noted one oddity about the way the machine is set up: in the BIOS, the graphics card (single 7950 GTX) is listed under the secondary slot, not the primary (I believe the terms used are parent and child, or similar). Can anyone confirm that this is a common setup, or could it cause problems?

    Alrighty, well if you're still awake I'd love to hear from ya.

    Cheers,


    /Uffe Sjostedt

  • #2
    OK - spoke too soon. Updates follow.

    BIOS: no news. Will probably get it tomorrow (I'm in Australia so although Monday's pretty much been and gone as far as I'm concerned, you lazybones in the States are only just waking up).

    Vista: seems more stable with the updates I just installed. They were:
    - Sound 6.0.1.5523
    - WLAN 11.5.0.32
    - GBLAN 6.200.1130.2007
    I didn't try them one by one or anything.
    I've also got the latest off laptopvideo2go, but haven't installed it yet.

    Linux: runs. Still complains about the BIOS handoff, but the hanging-at-boot thing seems related to how the machine was shut down. Specifically, I've had it work after Restarting out of Vista and fail after rebooting out of Linux. But please note I haven't had time to test any of this so it's more of a gut feeling right now.
    Then again, my gut's made of an advanced polymer and it doesn't know what the hell it's talking about. Stupid gut.


    /Uffe

    Comment


    • #3
      Linux update: added pci=nobios to the boot parameters. Still get the error message, but it now boots every time. This is still using the non-upgraded BIOS.

      Here's what I got out of the box with Debian etch r1:
      - Sound
      - USB (tested mouse and memory stick)
      - Touchpad
      - Battery indicator
      - GBLAN (discovered, but I haven't actually tested it)
      - DVD player (haven't tested burning)
      - Bluetooth (discovered, not tested)

      I haven't tested the WLAN yet at all. Might be all OK, might not.

      The initial install of X.org started up in non-accelerated safe mode, but I ran it in probe mode (from Linux single-user mode), and it picked up the 7950 GTX just fine. So basically all's well on the Linux front.


      /Uffe

      Comment

      Working...
      X