• Welcome to XOTIC PC Forums! If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Problems with ASUS G2S-A1

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with ASUS G2S-A1

    Hello,

    I just got my ASUS G2S-A1 today. The first time I booted it, there were no issues. It started normally. I installed the latest versions of Adobe Flash, Java, Mozilla, and the PC performance applet from Futuremark. When I tried to boot it again, it would just freeze halfway through the booting process. It could still be booted to safe mode, however. I tried a few system restores to points before I did anything today, but no luck so far.

    I just messed around with it some more. After the restores failed, I started trying to remove the external hardware. After removing the power cable, it worked. I put everything back in except the power cable, it still worked. I put everything in including the power cable and it would freeze during boot up.

    Anyone know what's going on?

  • #2
    I would recommend contacting technical support at 1-(888) 678-3688 (Option 3) (24/7 Domestic Tech Support) if no solution is offered here

    Comment


    • #3
      Maybe if you got your power cable or power input on your laptop checked out. I would start out by having Xotic send you a replacement power brick first, and if that doesn't work it is probably an internal issue. Also, one of the performance programs you installed may be malfunctioning, causing your computer power management to mess up when its plugged in. If you don't have too much stuff on your computer, you can always do a quick wipe and reinstall.
      Sager NP5792

      Microsoft Windows Vista Premium 64-Bit
      17" WUXGA
      Intel Core 2 Duo T7700 2.4GHz
      4 GB DDR2 667 RAM
      1 GB Intel Robson Turbo Memory
      500 GB 7200RPM Seagate Momentus HD
      nVidia GeForce 8800M GTX 512MB GDDR3

      FORUM TROLL 4 LIFE
      http://teamamerimixwcg.blogspot.com/...online_05.html

      Comment

      Working...
      X